SD WA - Při překročení 1024 znaků v příjemcích zprávy nelze založit požadavek ani událost
Článek se týká verzí produktů
ALVAO Service Desk 10.0 a vyšší
Příznaky
Sloupec sActTo v databázi (tabulka tAct) je omezen na 1024 znaků.
Do verze 10.4 jsme tuto velikost navýšili na 2048 znaků.
Pokud je zpráva určená 2 a více příjemcům, je výsledný řetězec ve formátu: Jméno Příjmení (e-mail); Jméno Příjmení (e-mail);...
Totéž pak platí po položku Kopie (sActCc).
Příčina
Příčinou je chyba v produktech ALVAO.
Řešení
Opraveno ve verzi 10.4.1319 - 10.4/FIX2 (3.6.2021)
Náhradní řešení
Do verze 10.4 FIX2 nezakládat požadavek e-mailem vyčteným z poštovní schránky, pokud pole Komu nebo Kopie obsahuje více než cca 25 příjemců (obsahující více než 1024 znaků).
Workround je rozdělit příjemce mezi Komu a Kopie.
Kroky pro reprodukci tohoto chování
Založit požadavek e-mailem a přitom mít v poli Komu nebo Kopie enormní množství příjemců (cca 25 a více).
Přílohy
Číslo problému
T111458ALVAO
Nenašli jste co jste hledali? Zeptejte se našeho týmu technické podpory.
|