SD - Požadavek - Schválit - Chyba "Příkaz nelze použít, protože nemáte oprávnění k požadavku 123, nebo během Vaší práce byly změněny podmínky k použití příkazu."
Článek se týká verzí produktů
ALVAO Service Desk 10.4 a vyšší
Příznaky
Pokud proces obsahuje více schvalování, přičemž po schválení jednoho automaticky začíná další, po odeslání formuláře Schválit/Zamítnout požadavek se může objevit chyba "Příkaz nelze použít, protože nemáte oprávnění k požadavku 123, nebo během Vaší práce byly změněny podmínky k použití příkazu.".
Příčina
Příčinou je chyba v produktech ALVAO.
Řešení
Opraveno ve verzi 10.4.2135 - 10.4/SP1 FIX5 (7.10.2021)
Náhradní řešení
Druhé schvalování zahajovat ručně a ne automaticky. Ruční zahájení obstará řešitel/operátor požadavku.
Nebo schvalovateli prvního schvalování přidejte např. roli čtenáře na službě, která mu zajistí právo zahájit druhé schvalování.
Kroky pro reprodukci tohoto chování
- Proces je nastaven tak, že se automaticky zahajuje schvalování ve dvou různých stavech. Každé schvalování má jiného schvalovatele, přičemž na službě procesu nemají žádná oprávnění. Při schválení prvního schvalování se přechází do stavu, na kterém je nastaveno druhé schvalování.
- Vznikne požadavek, který přejde do stavu s prvním schvalováním.
- Schvalovateli přijde oznámení a přes formulář požadavek schválí.
- Objeví se mu ale chyba, protože systém zablokuje zahájení druhého schvalování, protože na to tento uživatel nemá oprávnění.
Přílohy
Číslo problému
T117650ALVAO
Nenašli jste co jste hledali? Zeptejte se našeho týmu technické podpory.
|