Skip Navigation Links Skip Navigation Links.


SD CA - Alvao API - Ticket.Create with IgnoreRights=true fails if the first ticket status is approval

Článek se týká verzí produktů

ALVAO Service Desk 10.4 a vyšší

Příznaky

Following message or exception is generated: The command cannot be used because you don't have authorization for the ticket {0}, or during your work the conditions for using the command have changed.

Příčina

The cause is a bug in ALVAO products.

Řešení

Opraveno ve verzi 11.2.3067 - 11.2/SP1 (release 2024-09-19)

Náhradní řešení

Change the process that way, so the first status is not an approval.

Kroky pro reprodukci tohoto chování

Use service with process that has approval in the first status. Call method Ticket.Create and set the IgnoreRights property of the NewTicketModel to true.

Přílohy

Číslo problému

T159749ALVAO

 

Nenašli jste co jste hledali? Zeptejte se našeho týmu technické podpory.