54035 - ALVAO - Admin - nelze vytvořit databázi na serveru který má
např. PL jazyk
Článek se týká verzí produktů
8.1.752, 8.1.1070.
Příznaky
Nelze upgradovat databázi ALVAO. Upgrade zahlásí chybu, že nezná
uživatele "NT AUTHORITY\SYSTEM", protože např. na polském serveru se účet
jmenuje jinak.
Příčina
Příčinou je chyba v produktech ALVAO. Skript nepočítá s variantou, že se
systémový účet jmenuje jinak, než "NT AUTHORITY\SYSTEM".
Řešení
Opraveno ve verzi 8.2.1187.
Náhradní řešení
- Otevřete soubor "DbUpgrade94a.ast", který se standardně nachází v
adresáři "C:\Program Files (x86)\ALVAO\Admin\Database\[cislo
jazykove mustace databaze]".
- Na pátý řádek doplňte před "EXEC sp_addrolemember 'db_owner', 'NT
AUTHORITY\SYSTEM';" dvě pomlčky, čímž zakomentujete SQl kód.
- Uložte soubor.
- Nyní by měl upgrade proběhnout v pořádku.
Další informace
Zakomentovaný kód přiřazuje systémovému účtu roli db_owner na ALVAo
databázi. Toto je důležité, pokud používáte produkt Monitoring nebo modul
HW/SW Usage Monitoring a současně je vaše databáze umístěna na SQL Serveru
2012 nebo novějším.
Pokud se vás tento případ týká, doporučujeme systémovému účtu (resp.
účtu, pod kterým běží služba Monitoring Server) přidat roli db_owner ručně.
Nenašli jste co jste hledali? Zeptejte se našeho týmu technické podpory.
|