62146 - AM - Po upgrade databáze se mohly
přejmenovat některé vlastnosti a ikony
Článek se týká verzí produktů
ALVAO Asset Management 8.2 RTM, FIX1,2,3,4
Příznaky
- Po upgrade databáze se
přejmenovaly některé vlastnosti
nebo ikony nebo obojí.
- Pokud si nejste jistí, zda
se chyba stala i u Vás,
postupujte dle návodu v kap.
"Náhradní řešení".
- Pokud se u vás chyba
projevila, je třeba provést
ruční opravu - viz kap.
"Náhradní řešení".
Příčina
Příčinou je chyba v produktech ALVAO.
Řešení
Opraveno ve verzi 8.2.1570.
Náhradní řešení
Oprava se nedá provést automaticky - zde je popsán pouze diagnostický
skript. Ten vypíše, které vlastnosti a ikony mohly být chybou postiženy.
Přejmenování je pak potřeba provést ručně pomocí AM Console.
Pozn.: Diagnostický skript je univerzální pro
libovolný jazyk databáze.
Postup:
- Na databázi spusťte
tento skript.
- Skript vypíše vlastnosti a
ikony, které mohly být postiženy
chybou a tedy mohly být při
upgrade databáze přejmenovány.
- Pozn.: Skript zobrazí
správné výsledky, pouze pokud
jste DB upgradovali verzí
uvedenou výše.
- Pokud skript nevypíše
žádné řádky,
tak databáze nebyla
touto chybou ovlivněna.
- Pokud skript vypíše nějaké
záznamy tak postupujte takto:
- Spusťte AM
Console.
- Podle
sloupce "Typ",
(kde bude
uvedeno zda se
jedná o ikonu
nebo definici
vlastnosti)
použijte v AM
Console příkaz
"Nástroje -
Seznamy
[Ikony... |
Definice
vlastností...]".
- Najděte
ikonu/vlastnost
dle názvu
vypsaného ve
sloupci "Název".
Pozn.:
Ikon/vlastností
může být se
stejným názvem
více, je třeba
tedy nalézt tu
správnou, např.
dle obrázku
ikony (nesedí
popis a
obrázek), nebo
dle definice
vlastnosti
(nesedí název a
definice
vlastnosti).
- Upravte
ikonu/vlastnost
a změňte název
na původní název
Pozn.: Text ve
sloupci
"Systémový
(původní) název"
může napovědět
původní název
ikony/vlastnosti.
Zobrazí se ale
pouze u ALVAO
systémových
vlastností.
Pokud se
přejmenovala
vaše vlastní
ikona/vlastnost,
v tomto sloupci
bude pouze znak
"?" - skript
totiž nedokáže
zjistit, jak se
vaše
ikona/vlastnost
původně
jmenovala.
Pokud si nevíte rady, nebo si netroufáte diagnostiku/opravu provést sami,
kontaktujte prosím technickou podporu ALVAO.
Nenašli jste co jste hledali? Zeptejte se našeho týmu technické podpory.
|