Database upgrade takes a long time
This article is about product releases
ALVAO Service Desk 10.3 and higher
Symptoms
Upgrading the database takes several hours, or it may not even finish because, for example, the disk space where tempdb is located runs out.
Cause
The cause is a bug in ALVAO products.
Solution
Fixed in release 11.1.1096 - 11.1 (2023-04-13)
Workaround
1. Projděte všechny definované SLA v systému a zakažte u nich možnost "Pozastavit SLA při čekání na žadatele".
2. Aktualizujte databázi.
3. Pokud pozastavení skutečně používáte, opět jej na vybraných SLA zapněte.
Poznámka: Pro hromadné vypnutí/zapnutí volby můžete využít skript z příloh. Postupujte podle instrukcí v komentářích skriptu.
Steps to reproduce this behavior
There are tens of thousands of requests in the database that have "Suspend SLA while waiting for requester" enabled on their SLA.
The upgrade then recalculates the start of the SLA pause for each request, which can take several seconds per request.
Issue number
T103405ALVAO