SD - Request Tables - Views - the displayed custom columns of users, organizations, services, and SLAs can disappear from the view
This article is about product releases
ALVAO Service Desk 10.1 and higher
Symptoms
Custom columns of users disappear from the requirements view. organizations, services, and SLAs.
Custom user columns, etc., disappear from the view whenever a new custom request item is created.
Cause
The cause is a bug in ALVAO products.
Solution
Fixed in release 11.1.1096 - 11.1 (2023-04-13)
Workaround
Use the script in the attachment to set the users to the request table views again. After the script is applied, the custom columns of the other entities are no longer removed when a new custom request entry is created.
The script from the attachment creates auxiliary custom columns in the database. Please do not delete these columns
Steps to reproduce this behavior
Add a custom person column to the view.
Create a new custom request item.
The custom person item in the view disappears.
Issue number
T106198ALVAO