500 error "Status of the request cannot be changed because the request is under approval" after the creation of a request with assign to the solver
This article is about product releases
ALVAO Service Desk 10.1 and higher
Symptoms
500 error "Status of the request cannot be changed because the request is under approval" is shown after the creation of a request with assign to the solver.
Cause
The cause is a bug in ALVAO products.
Solution
Fixed in release 11.1.1096 - 11.1 (2023-04-13)
Workaround
-
Steps to reproduce this behavior
New requests in the service are automatically subject to approval (settings - approval is triggered in the New state).
At the same time, when the request is first handed over to the solver, the status should be automatically changed to Solution (another process setting).
1. New request form
2. Select the Assign to solver option
3. Create a request
3. It shows error 500
Attachments
Issue number
T139022ALVAO