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ALVAO Service - Detection evaluation does not work, an error in log is displayed: "System.NullReferenceException: Object reference not set to an instance of an object"

This article is about product releases

ALVAO Asset Management 11.1 and higher

Symptoms

The log shows an error:

System.NullReferenceException: Object reference not set to an instance of an object.
  at Alvao.Service.Models.Detection.HwData.CheckAndUpdate()
  at Alvao.Service.Models.Detection.HwData.UpdateTreeByDetect()
  at Alvao.Service.Services.Implementation.DetectionsService.EvaluateDetections(CancellationToken cancellationToken)
  at Alvao.Service.Tasks.Implementation.EvaluateDetectTask.Action(CancellationToken cancellationToken)
  at Alvao.Service.Tasks.PeriodicAfterPreviousTask.RunAsync(CancellationToken cancellationToken)
This error occurs over and over (many times per minute).

Cause

The cause is a bug in ALVAO products.

Solution

Fixed in release 11.1.1344 - 11.1/FIX2 (2023-06-01)

Workaround

  1. Stop the Alvao Service
  2. Run the following query over the database:
    select
      n.intNodeId 'NodeId',
      n.txtName 'Computer name',
      n.txtPath 'Path in tree',
      case when d.lintDetectKindId=1 then 'HW' else 'SW' end 'Detect type'
    from tblDetectAction da
      join tblDetect d on d.intDetectId=da.lintDetectId
      join tblNode n on n.intNodeId=d.lintComputerNodeId
    where da.txtCollector='$Alvao.Service$'
    
  3. Find the problem computer and the appropriate detection and remove it (this detection is faulty).
  4. Start the Alvao Service - the error should no longer occur.
Note: For the query, you can use AM Console - Tools - Database - SQL query window or the new Data queries agenda.

Steps to reproduce this behavior

Attachments

Issue number

T143494ALVAO

 

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