SD: Notifications - Custom notification from some service is not sent, standard notification is generated instead
This article is about product releases
ALVAO Service Desk 11.1 and higher
Symptoms
Custom notification from some service is not sent, standard notification is generated instead.
Cause
If ANY user has set DO NOT SEND on this type of custom notification of the selected service, system wrongly interpret that as if this kind of notification should not be send.
Solution
Fixed in release 11.1.2214 - 11.1/SP1 FIX7 (2023-12-07)
Workaround
select * from tHdSectionPerson
where liHdSectionPersonHdSectionId = @sectionId
If column liHdSectionPersonPersonId has any other value than NULL and under the notification column of some type (etc. liHdSectionPersonPersonId) is value 0, this user/s (under its ID) needs to enable this kind of notification.
Ask this user if he can momentarily ENABLE this notification to be sent to him.
Steps to reproduce this behavior
Set custom notification (of any kind) on the selected service.
Attachments
Issue number
T150399ALVAO