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SD CA - Alvao API - Ticket.Create with IgnoreRights=true fails if the first ticket status is approval

This article is about product releases

ALVAO Service Desk 10.4 and higher

Symptoms

Following message or exception is generated: The command cannot be used because you don't have authorization for the ticket {0}, or during your work the conditions for using the command have changed.

Cause

The cause is a bug in ALVAO products.

Solution

Fixed in release 11.2.3067 - 11.2/SP1 (2024-09-19)

Workaround

Change the process that way, so the first status is not an approval.

Steps to reproduce this behavior

Use service with process that has approval in the first status. Call method Ticket.Create and set the IgnoreRights property of the NewTicketModel to true.

Attachments

Issue number

T159749ALVAO

 

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