Skip Navigation LinksALVAO 11.1Known issues Skip Navigation Links.


ALVAO products/ALVAO Microsoft Intune Connector: an error "The string 'Device not found in Intune' was not recognized as a valid DateTime" is shown in the log

This article is about product releases

ALVAO Microsoft Intune Connector 11.1 and higher

Symptoms

- there is an error "The string 'Device not found in Intune' was not recognized as a valid DateTime" in the log
- in the asset object tree, there is a device, with non-datetime value int the "Intune last check-in" property.

Cause

The cause is a bug in ALVAO products.

Solution

Fixed in release 11.2.1534 - 11.2/FIX4 (2024-08-01)

Workaround

  1. Go to the Objects, switch to the table view and in the table, display the column "Intune last check-in"
  2. Filter values in the column to find non-datetime values
  3. For each found device:
    • If the value in the property "Intune last check-in" is "Device not found in Intune", it means this device is no longer in the MS Intune:
      • If you want to keep the device in the Asset management, delete the value from the property "Intune device ID".
      • OR Completely delete the device from the Asset management (also from the recycle bin).
    • If it is another value:
      • Go to the object detail
      • Edit the property "Intune device ID" and cut the value to the clipboard, and replace it by empty value (to unlock editing on the "Intune last check-in" property).
      • Edit the property "Intune last check-in" and replace the non-datetime value by empty value.
      • Edit the property "Intune device ID" and return value from the clipboard (to keep device linked to the MS Intune).

Steps to reproduce this behavior

Attachments

Issue number

T162819ALVAO

 

Did not find what you were looking for? Ask our technical support team.