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Alvao Service - Sending messages: Error when sending SLA alerts

This article is about product releases

ALVAO Service Desk 11.0 and higher

Symptoms

SLA alerts are not sent. There is an error in Alvao Service log.

Cause

The cause is a bug in ALVAO products.

Solution

Fixed in release 11.2.3067 - 11.2/SP1 (2024-09-19)

Workaround

Go to database and start following SQL SELECT query to get records of of invalid SLA rules.


select s.iSlaId, s.sSla, r.*
from tSlaAlertRule as r
inner join tSla as s on s.iSlaId = r.liSlaId
where r.InternalTargetExpireHours is null
 and r.fDeadlineExpireHours is null
 and r.FirstReactionExpireHours is null
 and r.liInactiveRoleStringId is null
Find the invalid SLA rule in Administration, check the configuration and save it.

Steps to reproduce this behavior

There is an invalid setting in SLA rule.

Attachments

Issue number

T163068ALVAO

 

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