New ticket - Self assign (option) - new ticket stays in initial status despite self assignment
This article is about product releases
ALVAO Service Desk 10.3 and higher
Symptoms
The ticket status does not change when self assigning while creating the ticket when the next status has a required field.
Cause
The cause is a bug in ALVAO products.
Solution
Fix planned for release 26.1 (code freeze 2026-01-05; 2026-02-05)
Workaround
Create the ticket and then assign it, or manually transition to wanted status.
Steps to reproduce this behavior
Set required field for the status which the ticket is being transitioned to when assigning a ticket. Then create a ticket in a service which has that process, click on self assign in the ticket creation form, then create the ticket -> ticket's status does not change.
Attachments
Issue number
T186433ALVAO