WA – Administration – SD – Opening hours and Intervals – Error 500 timeout / First response reaction time is computed incorrectly
This article is about product releases
ALVAO Service Desk 10.0 and higher
Symptoms
500
an error occurred in the application.
An error occurred while processing the page 'Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding. temp table created 3.33333ms'.
Cause
The cause is a bug in ALVAO products.
Solution
Fixed in release 11.0.2043 - 11.0/SP1 (2022-09-15)
Workaround
After this timeout occurs, run manually exec dbo.spOpeningHoursCache_Update in the SQL Server Management Studio to recache necessary data.
Steps to reproduce this behavior
Try to create or delete entry in the Opening hours table.
Database quesry:
select * from tOpeningHoursCache
Returns somewhere between more than 30-40 thousand rows depending on SQL Server.
Attachments
Issue number
T127167ALVAO