Software products library - Updates from the web: Library is not updated and software installation is not recognized
This article is about product releases
ALVAO Software Asset Management 10.0 and higher
Symptoms
Software recognition is not working correctly.
Software is not recognized.
Cause
The cause is a bug in ALVAO products.
Solution
Fix planned for release 26.1 RTM (code freeze 2026-01-05; 2026-02-05)
Workaround
There is high possibility that old Alvao Asset Management Collector data are blocking the upgrade process.
Run the query: select * from tblSwLibUpdate
If you see a record with some NAME and OLD date, you need to remove this record from the table.
Run this query to remove the record: delete from tblSwLibUpdate
Restart Alvao Service (if you still use Collector, restart that application).
It should soon start update process. You can see that Alvao Service starts updating the library if you run the first query again (few times).
After the upgrade is done, table should be empty.
Steps to reproduce this behavior
Attachments
Issue number
T187535ALVAO