Skip Navigation LinksALVAO 11.2Admin guideTroubleshootingKnown issues Skip Navigation Links.


Skip Navigation LinksALVAO 11.2 / Admin guide / Troubleshooting / Known issues

AAD User provisioning (SCIM) - Incremental cycle quarantined - The target application returned a response without an 'id'

This article is about product releases

ALVAO 11.0 and higher

Symptoms

Provisioning quarantined with an error:
The target application returned a response without an 'id'. This 'id' attribute is required per section 3.1 of SCIM RFC 7643. Please contact the application developer and request that they return the 'id' property in the SCIM response.

Cause

The cause is a bug in ALVAO products.

Solution

Fixed in release 11.2.1134 - 11.2 (2024-04-11)

Workaround

  1. Find an Object Id of a group in AAD
  2. Find the group in a Alvao database table tRole and set a value from previous step to column AzureObjectId.
  3. Restart provisioning
Workaround 2 (during upgrade to 11.2)
  1. Stop provisioning
  2. Upgrade ALVAO to 11.2
  3. Run SQL script: exec spUpdateInsertProperty 'Scim.UseOldGroupIdentifiers', null, 0
  4. Set up a new application for user provisioning in MS Entra with same settings as previous and start provisioning

Steps to reproduce this behavior

  1. There is a group in Alvao - Administration and AAD with the same name
  2. Set up a user provisioning

Attachments

Issue number

T147766ALVAO

 

Did not find what you were looking for? Ask our technical support team.