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MS Entra - User provisioning (SCIM) - Bad request: An item with the same key has already been added.

This article is about product releases

ALVAO 11.2 and higher

Symptoms

Result: Failure
Description: Failed to match an entry in the source and target systems User 'xxx.yyy@zzz.com'
ErrorCode: SystemForCrossDomainIdentityManagementServiceIncompatible
ErrorMessage: Received response from Web resource. Resource: https://contoso.onalvao.com/AlvaoRestApi/scim/Users?filter=externalId+eq+"abc1f05e-a3e8-4404-81f5-f37213472123" Operation: GET Response Status Code: BadRequest Response Headers: Connection: keep-alive Date: Thu, 29 Feb 2024 12:09:38 GMT Set-Cookie:'[Redacted]';Domain=contoso.alvao.com ARRAffinitySameSite='[Redacted]';Path=/;HttpOnly;SameSite=None;Secure;Domain=contoso.onalvao.com Server: Microsoft-IIS/10.0 Request-Context: appId=cid-v1:93215edb-a123b-4177-8e01-1b223fd03744 X-Powered-By: ASP.NET Response Content: "An item with the same key has already been added. Key: kindId_269" . This operation was retried 0 times. It will be retried again after this date: 2024-02-29T12:09:38.6947750Z UTC
ReportableIdentifier: xxx.yyy@zzz.com

Cause

The cause is a bug in ALVAO products.

Solution

Fixed in release 11.2.1347 - 11.2/FIX1 (2024-05-16)

Workaround

Have only one user template.

Steps to reproduce this behavior

  1. Set up multiple (at least 2) templates for User object type in AM
  2. Set up user provisioning in MS Entra

Attachments

Issue number

T156872ALVAO

 

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