SD - Request - Automatic transition to status according to approval result not possible on process change without required field
This article is about product releases
ALVAO Service Desk 11.0 and higher
Symptoms
There is an error message when trying to approve or reject approval that transits to the state with required field:
The operation cannot proceed because the required fields are not filled "". Fill these fields.
The required field is not visible in Edit dialog. User cannot set the required field.
Cause
The cause is a bug in ALVAO products.
Solution
Fix planned for release 11.3/RTM (2025-04-10)
Workaround
Change the process of the service to the previous value. Finish all active approvals on the tickets of the changed service. Set the process to the new value.
Steps to reproduce this behavior
1. Use process that contains approval status with automatic transition to status according to approval result. End statuses contain required field.
2. Start the approval process in the ticket that has the approval status.
3. Change the process of the service to a new one, that does not contain required fields.
4. Approve/reject/cancel the approval to transit to new status with required field according to old process.
5. Click the link "Fill these fields" to open Edit dialog with required fields
Attachments
Issue number
T158201ALVAO