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SD Enterprise API - Filter records with custom field value - Invalid column name 'myCustomItem'

This article is about product releases

ALVAO Service Desk 11.2 and higher

Symptoms

API returns error 500: Invalid column name 'myCustomItem'

Cause

The cause is a bug in ALVAO products.

Solution

Fix planned for release 11.2/FIX2 (2024-06-06)

Workaround

Create new custom field with lower case first letter (field Column) and use it instead.

Steps to reproduce this behavior

  • Create ticket custom field with upper case first letter, eg. MyCustomItem. in field Column.
  • Filter tikets using this custom item, eg. AlvaoRestApi/v1/tickets?$filter=MyCustomItem eq 'that value'
Apply also for all endpoints supporting filtering by custom items: users, services and organizations.

Attachments

Issue number

T158379ALVAO

 

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