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Intune Connector - an error "The wait operation timed out" is shown in the log

This article is about product releases

ALVAO Microsoft Intune Connector 11.2 and higher

Symptoms

An error:

Alvao.Service.Services.Implementation.IntuneService.ImportDevices Error importing devices from Intune.
Microsoft.Data.SqlClient.SqlException (0x80131904): Execution Timeout Expired.  The timeout period elapsed prior to completion of the operation or the server is not responding.
Operation cancelled by user.
The statement has been terminated.
---> System.ComponentModel.Win32Exception (258): The wait operation timed out.
  ...
  at Alvao.Service.Repository.Implementation.IntuneRepository.ClearIntuneDeviceLastCheckinLogs()
  at Alvao.Service.Services.Implementation.IntuneService.ImportDevices(CancellationToken cancellationToken)
is shown in the log.

Cause

The cause is a bug in ALVAO products.

Solution

Fixed in release 11.2.3067 - 11.2/SP1 (2024-09-19)

Workaround

Run the following SQL script on the database:

delete l
from tblLog l
    join tblKind k on k.intKindId=l.KindId and k.intKindCode=168
    join tPerson p on p.iPersonId=l.liLogPersonId and p.bPersonSystem=1

Steps to reproduce this behavior

Attachments

Issue number

T160051ALVAO

 

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