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Intune Connector - an error "Error importing devices from Intune. System.Net.Http.HttpRequestException: Not Found" is shown in the log

This article is about product releases

ALVAO Microsoft Intune Connector 11.1 and higher

Symptoms

In the log, there is an error:

Alvao.Service.Services.Implementation.IntuneService.ImportDevices Error importing devices from Intune.
System.Net.Http.HttpRequestException: Not Found, URL: managedDevices/[intune device ID]?$select=Id,LastSyncDateTime,DeviceName,OperatingSystem,...
   at Alvao.Service.Services.Implementation.IntuneService.GetGraphApiResponse(String subUrl, CancellationToken cancellationToken)
   at Alvao.Service.Services.Implementation.IntuneService.GetManagedDeviceDetail(String id, CancellationToken cancellationToken)
   at Alvao.Service.Services.Implementation.IntuneService.UpdateExistingDevicesWithoutIntuneLastCheckInValue(CancellationToken cancellationToken)
   at Alvao.Service.Services.Implementation.IntuneService.ImportDevices(CancellationToken cancellationToken)
Note: It is also possible, that another devices,, without "Intune last check-in" value and with "Intune device ID" value won't be updated until the error will be resolved.

Cause

The cause is a bug in ALVAO products.

Solution

Fixed in release 11.2.1486 - 11.2/FIX3 (2024-07-04)

Workaround

1. Find the device with a specific "Intune device ID", that is causing the error in the Asset Management.
2. This device no longer exists in the Microsoft Intune, so you can delete it from the Asset Management and the error should disappear.

Steps to reproduce this behavior

Attachments

Issue number

T160074ALVAO

 

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