Log - Event: REST API - tickets/{ID}/log - POST - type E-mail - Does not generate email message
This article is about product releases
ALVAO Service Desk 10.4 and higher
Symptoms
REST API: New event in the log of the ticket - event type is an e-mail.
Expectations: Message will be send from the ticket to recipients.
Reality: Nothing is sent to recipients. REST API currently does not generate notifications from this endpoint.
Cause
The cause is a bug in ALVAO products.
Solution
Fixed in release 11.2.3125 - 11.2/SP1 FIX5 (2024-10-03)
Workaround
In combination with SD Custom Apps and OnActCreated it is possible to send a message via ALVAO.API library and Email.Queue action (we recommend Rebex model variant, System.Net.Mail model will be removed in the next version).
Link to the API documentation: Email.Queue.
Steps to reproduce this behavior
Attachments
Issue number
T162436ALVAO