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Tickets - Ticket: Approval status (mostly ad-hoc mode) - Settings on this status has been changed - Ticket can't change status nor can be resolved

This article is about product releases

ALVAO Service Desk 10.4 and higher

Symptoms

One or more tickets can't change their status nor can be resolved nor can be changed service with different process.

Cause

The cause is a bug in ALVAO products.

Solution

Fix planned for release 11.3/RTM (2025-04-10)

Workaround

Revert status settings to approval enabled and transit to all states.

Or use custom application from file attachments.
In this application: change ids in Settings script and write ids (or just one id) of tickets that you need to resolve.
On these tickets, new custom command apprears: Ticket close - force.
This command will try the following: cancel ongoing approval or all approval steps, resolve or close the ticket.
In the case this application is not working, you can modify the code to see more error information.

Steps to reproduce this behavior

On these tickets, there is most likely ongoing approval.
You can check if approval is still ongoing on the ticket itself via SSMS (tHdTicket.ApprovalId).
Type of this approval is ad-hoc -> type of approval where you can add more approvers until status of that ticket has been changed (in status settings: enabled approval and choice transit to all states).
If this status settings was changed to different type of approval, these tickets are now blocked and nothing can be done from WebApp user interface.

The second possibility for this bug is if this specific status was REMOVED.

Attachments

Issue number

T166023ALVAO

 

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