Administration - Service Desk - Services - Service - Service catalogue - New ticket form - Custom form, ...: Hidden custom fields cause validation errors
This article is about product releases
ALVAO Service Desk 11.2 and higher
Symptoms
The form displays validation errors for custom fields that were hidden and user could not fill them in.
It is not possible to successfully submit data from custom New ticket form.
Cause
The cause is a bug in ALVAO products.
Solution
Fix planned for release 25.1/RTM (2025-04-10)
Workaround
Split the ColumnsControl to two different instances. One instance can contain columns/fields that can be hidden. The second instance of ColumnsControl will contain fields that are always visible.
Steps to reproduce this behavior
Create custom New ticket form.
Use ColumnsControl control in the CSHTML file (contains the view). Specify multiple RequiredColumns.
Hide some empty custom fields in the form using javascript code based on selected options etc.
At least one custom field must be visible.
Submit the form.
Attachments
Issue number
T172077ALVAO